[CAF] Configuration Problem

Michael Graham magog at the-wire.com
Mon Oct 3 04:43:40 EDT 2005


Hi Bill,

Thanks for the report!

We'll have to look into this.  The load_music_data.pl script doesn't get
a lot of heavy use, so it tends to get out of sync with the rest of the
Framework.

I believe you can try transposing the order of the use lines in
load_music_data.pl.  So change this:

    use CDBI::Example::example;

    use example_1;

to this:

    use example_1;
    use CDBI::Example::example;

If you still get an error, you may also try:

    use base 'CGI::Application';
    use example_1;
    use CDBI::Example::example;

Let us know how it goes.


Michael


On Sun, 2 Oct 2005 20:55:20 -0400
Bill Birkett <wbirkett at doplganger.com> wrote:

> Hello-
>
> I spent today trying to get CAF installed and operational. I got it
> to pass all the 'make' tests, but ran into problems getting the
> examples to work.
>
> I'm using MyQSL, and followed the directions for configuring the
> example database. When I got to the part of adding the additional
> database information, here is what happened:
>
> [WebServer:caf/framework/sql] techadm% perl load_music_data.pl music_info.csv
> Can't locate object method "new_hook" via package "main" at
> /Users/techadm/Projects/ColorMatch_Server/CGI_Scripts/caf/framework/projects/Example/common-modules/CDBI/Example/example.pm
> line 50.
>
> "new_hook" is a method of CGI::Application, so it appears the
> inheritance chain to example.pm is broken. Any ideas on how to fix
> this?
>
> -Bill
> --
>
> William B. Birkett - <wbirkett at doplganger.com>
> Print Quality Consultant
> Doppelganger, LLC  - http://www.doplganger.com/
>
> 48799 Meadow Drive, Plymouth, MI 48170 (USA)
> Office: (734) 927-4232      FAX: (734) 468-0580
> Cell: (734) 516-4790

---
Michael Graham <magog at the-wire.com>




More information about the caf mailing list